ND Medicaid Missing in Metabase and Columns in Rules Engine
Resolved·Degraded performance
Thu, Oct 9, 2025, 03:28 PM
(1 week ago)
·
Affected components
RCM
Updates

Resolved

This incident has been resolved.

Thu, Oct 9, 2025, 03:28 PM

Investigating

We are actively investigating this issue, subscribe and stay tuned for updates.

Mon, Oct 6, 2025, 03:20 PM(3 days earlier)