Account is changing for billing specialist
Resolved·Degraded performance
Mon, Oct 13, 2025, 08:28 PM
(5 days ago)
·
Affected components
RCM
Updates

Resolved

This incident has been resolved.

Mon, Oct 13, 2025, 08:28 PM

Investigating

We are actively investigating this issue, subscribe and stay tuned for updates.

Tue, Oct 7, 2025, 07:46 PM(6 days earlier)