Cannot locate the location of duplicate auth numbers to upload for a provider to process billing.
Resolved·Degraded performance
Thu, Oct 9, 2025, 07:48 PM
(1 week ago)
·
Affected components
RCM
Updates

Resolved

This incident has been resolved.

Thu, Oct 9, 2025, 07:48 PM

Investigating

We are actively investigating this issue, subscribe and stay tuned for updates.

Wed, Oct 8, 2025, 06:06 PM(1 day earlier)