I was trying to use the Meta Base titled Billing By Payer And Client but I am not seeing some invoices
Resolved·Degraded performance

Reviewing the invoice shared by Izzy 4511967, it was noticed that it’s currently marked as “Overdue” on Receivable Invoices. Previously, the report included all invoices without any status restrictions. However, per Eugenia’s request last week, it was updated to only include invoices with the “Created” status in the Receivable Invoices table. In this case, the invoice doesn’t meet that condition, which is why it’s not showing up. The user was notified by teams, I will be monitoring with the team if they want to apply any change to the initial request.

Thu, Oct 16, 2025, 11:15 PM
(2 days ago)
·
Affected components
RCM
Updates

Resolved

Reviewing the invoice shared by Izzy 4511967, it was noticed that it’s currently marked as “Overdue” on Receivable Invoices. Previously, the report included all invoices without any status restrictions. However, per Eugenia’s request last week, it was updated to only include invoices with the “Created” status in the Receivable Invoices table. In this case, the invoice doesn’t meet that condition, which is why it’s not showing up. The user was notified by teams, I will be monitoring with the team if they want to apply any change to the initial request.

Thu, Oct 16, 2025, 11:15 PM

Investigating

We are actively investigating this issue, subscribe and stay tuned for updates.

Thu, Oct 16, 2025, 08:27 PM(2 hours earlier)