Causes: Instability in the HSRM website, a 1-hour hard limit of session time, and a high volume of providers associated with Nicole's acc. Investigation was done in: https://linear.app/paradigmseniors/issue/RCM-807/investigate-timeout-when-clicking-on-providers-details (more details of other incidents related to the instability of the hsrm website in the slack channel https://careswitch.slack.com/archives/C09P1NUHG1Z) Steps to resolve: Initial mitigation: https://linear.app/paradigmseniors/issue/RCM-830/allow-human-intervention-to-do-a-manual-filter-of-the-auths-before-rpa RCM-813/allow-the-bot-to-scrape-a-past-date-range https://linear.app/paradigmseniors/issue/RCM-832/deploy-the-bot-in-an-ops-machine-and-train-the-operator-to-execute-it Then continue with a broader plan to return the bot to the cloud with minimal human attention (ideally 0) and the highest possible success rate. The details of the plan are in linear tasks.
Identified
Causes: Instability in the HSRM website, a 1-hour hard limit of session time, and a high volume of providers associated with Nicole's acc. Investigation was done in: https://linear.app/paradigmseniors/issue/RCM-807/investigate-timeout-when-clicking-on-providers-details (more details of other incidents related to the instability of the hsrm website in the slack channel https://careswitch.slack.com/archives/C09P1NUHG1Z) Steps to resolve: Initial mitigation: https://linear.app/paradigmseniors/issue/RCM-830/allow-human-intervention-to-do-a-manual-filter-of-the-auths-before-rpa RCM-813/allow-the-bot-to-scrape-a-past-date-range https://linear.app/paradigmseniors/issue/RCM-832/deploy-the-bot-in-an-ops-machine-and-train-the-operator-to-execute-it Then continue with a broader plan to return the bot to the cloud with minimal human attention (ideally 0) and the highest possible success rate. The details of the plan are in linear tasks.
Investigating
We have not yet found the reason for the timeout on the auths details page when clicking on Provider Details. We are investigating that and performing other verifications to get more insights about the external system and mitigate this decrease in the bot's success rate.
Investigating
The HSRM bot’s lower number of inserted auths this month (a drop visible since September) is mainly due to downtime with Nicole’s account, when the bot couldn’t operate for several days. During that period, I’ve been running it locally once or twice a day to manually handle the SMS verification, which slightly reduces the success rate compared to the normal automated cloud runs. Regarding the “timeout” issue, it’s important to clarify that partial success and occasional session terminations are expected behavior, given how the HSRM system works. The bot must navigate paginated lists without direct page access, handle forced one-hour session limits, and recover from random site errors and logouts. It’s designed with retries and fallbacks to capture as much data as possible within those constraints, but it will never reach a 100% success rate. This behavior is effectively “working as intended.”, This is for the current logic, where it navigates through pages for all the auths for all providers. We are working on defining what approach to follow to address the feature "Trigger the bot for a specific provider" RCM-795, which we think will mitigate this decrease in success rate.
Investigating
We are actively investigating this issue, subscribe and stay tuned for updates.