The download option in the Receivables tab does not export data to Excel or PDF formats
Resolved·Degraded performance
Tue, Dec 30, 2025, 02:10 PM
(3 weeks ago)
·
Affected components
RCM
Updates

Resolved

This incident has been resolved.

Tue, Dec 30, 2025, 02:10 PM

Investigating

We are actively investigating this issue, subscribe and stay tuned for updates.

Mon, Dec 29, 2025, 03:16 PM(22 hours earlier)